LEGO Harry Potter: Years 1-4

  • LEGO Harry Potter: Years 1-4 Screenshot 1
  • LEGO Harry Potter: Years 1-4 Screenshot 2
  • LEGO Harry Potter: Years 1-4 Screenshot 3
  • LEGO Harry Potter: Years 1-4 Screenshot 4
  • LEGO Harry Potter: Years 1-4 Screenshot 5
  • LEGO Harry Potter: Years 1-4 Screenshot 6
  • LEGO Harry Potter: Years 1-4 Screenshot 7
  • LEGO Harry Potter: Years 1-4 Screenshot 8
  • LEGO Harry Potter: Years 1-4 Screenshot 9
  • LEGO Harry Potter: Years 1-4 Screenshot 10

Region restrictions

Activates within United States
Will NOT activate in the following countries:
Afghanistan, Belarus, Cuba, Iran, Islamic Republic of, Korea, Democratic People's Republic of, Kosovo, Myanmar, Russian Federation, South Sudan, Sudan, Syrian Arab Republic, Ukraine, Venezuela, Yemen, Zimbabwe.

Description

Requirements

Windows Requirements:
MINIMUM:
OS: Windows XP/Vista
Processor: Intel P4 1.8 GHz/AMD Athlon XP 2200+
RAM: 512MB
Graphics Card: ATI X1300/NVIDIA GeForce FX 5800 (256 MB RAM)
Sound Card: 100% DirectX®9.0c compatible audio device
Input Devices: Keyboard; Xbox 360 Controller for Windows supported
RECOMMENDED:
OS: Windows XP/Vista
Processor: Intel Core 2 Duo/AMD Athlon 64, 2.8GHz
RAM: 2GB
Graphics Card: ATI HD 2900/NVIDIA GeForce 8800
Sound Card: 100% DirectX®9.0c compatible audio device
Input Devices: Keyboard; Xbox 360 Controller for Windows supported
  • Requires Steam and a Steam Account to play Windows version.

Reviews & Comments

0
From 0 Shoppers
5
 
0
4
 
0
3
 
0
2
 
0
1
 
0
No reviews to list at this time.

More By Warner Bros. Interactive Entertainment

Buy with confidence!
MacGameStore / WinGameStore is an authorized retailer of digital products through relations with 1000+ publishers & developers. No gray-market worries here!
Doing business since the 90s
Originally began by shipping games in the 90s. Much has changed over the decades, and getting games into the hands of Mac & PC gamers is still our focus!
Ways to pay
Visa, Mastercard, Discover, American ExpressApplePayPayPal