Total War: WARHAMMER II – The Twisted & The Twilight

12/3/2020
Total War: WARHAMMER II – The Twisted & The Twilight
-17%
$8.29$9.99
  • Total War: WARHAMMER II – The Twisted & The Twilight Screenshot 1
  • Total War: WARHAMMER II – The Twisted & The Twilight Screenshot 2
  • Total War: WARHAMMER II – The Twisted & The Twilight Screenshot 3
  • Total War: WARHAMMER II – The Twisted & The Twilight Screenshot 4
  • Total War: WARHAMMER II – The Twisted & The Twilight Screenshot 5
  • Total War: WARHAMMER II – The Twisted & The Twilight Screenshot 6
  • Total War: WARHAMMER II – The Twisted & The Twilight Screenshot 7
  • Total War: WARHAMMER II – The Twisted & The Twilight Screenshot 8
  • Total War: WARHAMMER II – The Twisted & The Twilight Screenshot 9
  • Total War: WARHAMMER II – The Twisted & The Twilight Screenshot 10
  • Total War: WARHAMMER II – The Twisted & The Twilight Screenshot 11

Region restrictions

Activates within United States
Will NOT activate in the following countries:
Argentina, Bolivia, Brazil, Chile, China, Colombia, Cuba, Ecuador, Guyana, Hong Kong, Iran, Islamic Republic of, Japan, Korea, Democratic People's Republic of, Korea, Republic of, Kosovo, Paraguay, Peru, South Sudan, Sudan, Suriname, Syrian Arab Republic, Taiwan, Turkey, Ukraine, Uruguay, Venezuela.

Pre-Order Bonus

Description

Requirements

Windows Requirements:
MINIMUM:
OS: Windows 7 64bit
Processor: Intel® Core™ 2 Duo 3.0Ghz
Memory: 5 GB RAM
Graphics: NVIDIA GTX 460 1GB | AMD Radeon HD 5770 1GB | Intel HD4000 @720p
DirectX: Version 11
Storage: 60 MB available space
RECOMMENDED:
OS: Windows 7 / 8 (8.1)/ 10 64Bit
Processor: Intel® Core™ i5-4570 3.20GHz
Memory: 8 GB RAM
Graphics: NVIDIA GeForce GTX 770 4GB | AMD Radeon R9 290X 4GB @1080p
DirectX: Version 11
Storage: 60 GB available space
  • Pre-Order Game: Requirements Subject to Change
  • Requires Steam and a Steam Account to play Windows version.
Linux Requirements:
MINIMUM:
OS: Ubuntu 18.04 64-bit
Processor: 3.4GHz Intel Core i3-4130
Memory: 6 GB RAM
Graphics: 2GB Nvidia GTX 680 or better, 2GB AMD R9 285 (GCN 3rd Gen) or better
Storage: 60 GB available space
Additional Notes:
* Requires Vulkan
* Nvidia graphics cards require driver version 396.54 (tested)
* AMD GPU's require Mesa 18.1.5 or better (tested)
* Intel GPU's are not supported at time of release
RECOMMENDED:
OS: Ubuntu 18.04 64-bit
Processor: 3.4 GHz Intel Core i7-4770
Memory: 8 GB RAM
Graphics: 4GB Nvidia 970, 4GB AMD RX 480
Storage: 60 GB available space
Additional Notes:
* Requires Vulkan
* Nvidia graphics cards require driver version 396.54 (tested)
* AMD GPU's require Mesa 18.1.5 or better (tested)
* Intel GPU's are not supported at time of release
  • Pre-Order Game: Requirements Subject to Change
  • Requires Steam and a Steam Account to play Linux version.

Reviews & Comments

Reviews & Comments open on release.

More By Sega